PDA

View Full Version : Megadrive Modding Woes



Ogami
29-06-2004, 10:58 AM
I decided to dable in modding my PAL megadrive with a 50/60hz switch and a region switch, the region switch went fine and so i thought did the 50/60 switch.

after adding the 50/60 switch the screen was black and white like i expected, so i bought a RGB scart but it's still in black and white, so i re-done the switch incase anything went wrong and its ok, so i tried another guide i found and still the same problem of being in black and white, so my guess is a dodgy scart lead.

anyone else have any suggestions and where might i be able to get a proper rgb scart if that is the problem.

thanks.

MD
29-06-2004, 11:13 AM
Some TVs don't like the weedy +5V signal that some Megadrives give and won't switch to RGB.

Open up the lead and see if there if pins 7,11 and 15 are wired up as these are the RGB lines.

If so then check pin 16 and see if there is a resistor on this line, if so then unsolder it (or if you can twist the legs together) and solder it back in and see if that works.

We have some Sanyo TVs and no matter what I do I can't get the TVs to recognise Megadrive RGB (although it works with PS2 and SNES fine...).

Treble
29-06-2004, 11:15 AM
And if it turns out you really do need a new cable, VGI (http://www.videogameimports.com/hw_index.htm) do them.

Ogami
29-06-2004, 11:55 AM
Thanks i'll try those suggestions about the scart, i just tried it on a 10 year old telly and it worked fine in RGB mode, then i tried a 7 year old telly and it didnt work, and my tv i got last year doesnt like it either.

just checked inside the scart and theres no wire at all on point 16, the 3 rgb points you said were there though.

those leads at VGI can anyone vouch for them working on more modern tvs?